Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: arm64 boot hangs on Oracle Cloud Ampere (VM.Standard.A1.Flex)

On Wed, 16 Nov 2022 23:55:25 +0100, Štěpán Němec wrote:
> encouraged by the recent post[1] I'm trying to get NetBSD running on a
> (free) OCI VM. Unable to import a custom image (not possible on the Free
> Tier), I tried a method that I've had some success with on amd64 VMs,
> i.e., overwrite the root partition on a stock VM (Ubuntu Minimal
> aarch64) and booting that, with a serial console connection, i.e.
> (pseudoshell in the stock VM):
> cd $ramdisk_with_enough_space
> wget $image_url_below
> gunzip ...
> dd if=3Darm64.img of=3D/dev/sda ...
> [then reboot the VM]
> Unfortunately, the boot gets stuck after a few seconds (serial console
> output attached), the console doesn't seem to react to any keyboard
> input at that point, either.

I tried the same with a current 10.0 beta image and experienced the
same issue. However, when you change the shape of the instance
(changing the number of CPUs or memory assigned) after writing the
image to the boot volume, it then magically works.



https://cmeerw.org                             sip:cmeerw at cmeerw.org
mailto:cmeerw at cmeerw.org                   xmpp:cmeerw at cmeerw.org

Home | Main Index | Thread Index | Old Index