Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: trouble with netbsd-8 on RPI3?

Robert Swindells <rjs%fdy2.co.uk@localhost> writes:

> Greg Troxel <gdt%lexort.com@localhost> wrote:
>>Robert Swindells <rjs%fdy2.co.uk@localhost> writes:
>>> I have seen a similar error when trying to run an earmv4 userland with
>>> an earmv7hf kernel. I was trying to build some earmv4 packages on a
>>> faster machine.
>>> I fixed it by setting the CPU control flag to enable the deprecated SWP
>>> instruction.
>>Interesting, but I'm pretty sure that's not it.
> Why are you sure ?

Sorry, I meant that I was really sure that I did not accidentally build
and unpack an armv4 userland on my RPI3 system.  build.sh was invoked as

===> build.sh command:    ./build.sh -m evbearmv7hf-el -j8 -x -u -U -O /usr/obj/gdt-8/evbearmv7hf-el -T /usr/obj/gdt-8/tools -D /usr/obj/gdt-8/destdir/evbearmv7hf-el -R /usr/obj/gdt-8/releasedir -X /home/n0/gdt/NetBSD-8/xsrc release

via a script that has not been modified since my working build of Feb 15.

I am not at all sure what's wrong or why.

Thanks for the hint; will definitely save that and may be my next step.
(Didn't quote it because it's big, not because I didn't appreciate it.)

However, I tried reverting the kernel back to the file that I build on
February 15, and now one system (that I did that on) seems to be working
fine.  To be clear, it has userland from a May 7 checkout of netbsd-8,
and a kernel from a checkout soon before February 15th.

I will check this on the other two, and then I guess bisect the kernel.

Home | Main Index | Thread Index | Old Index