Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

earm(v5) not working on RPi


I've been trying to compile earmv4 and earm (v5) pkgsrc packages for NetBSD 8. For v4 I'm using an original Raspberry Pi B due to illegal instruction issues noted here:


For earm, I had tried to use an earmv7hf NetBSD 8 system (Jetson TK1) with an earm chroot, which generally works, but python programs and occasionally others in an earm chroot hang indefinitely. After updating the system to 8.1, compiling there is now too problematic.

So, instead, I've tried using a RPi3B+ with -current compiled for earm
from, I think, February. It worked decently, but the whole system was a bit unstable and would crash now and then.

Now I'm trying to set up this RPi 3B+ again, but it seems that earm is not working for RPi. The rpi.img.gz from:


simply stays on the rainbow screen.

The image from:


boots, then panics with "Process (pid 1) got sig 6".

Next, I tried the latest 32 bit generic image from invisible.ca, but with a fully earmv5 userland (not a chroot). But I get the same panic ("Process (pid 1) got sig 6").

Does anyone have any thoughts on running earm on a newer Pi?

John Klos

Home | Main Index | Thread Index | Old Index