Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Current build of netbsd for rpi is unable to boot

On 5 April 2014 12:36, Nick Hudson <skrll%netbsd.org@localhost> wrote:
> I changed my mind about having the hack in tree, but if you make sure you
> have
>     sys/arch/arm/include/arm32/param.h:1.22
> you should get a working RPI kernel.
> A proper fix is being worked on.
> Nick

Hi Nick,

that indeed gets me a kernel without the loop.  Thanks!  Can't wait
for the proper fix :-)

However, the new kernel does not see init for some reason - it's not a
filesystem issue, the old one still works
(NetBSD 6.99.28 (RPI) #1: Thu Dec  5 16:36:28 CET 2013)

Anyone else seeing this?  (I strongly doubt that these two issues are
related to each other BTW)

Please note I have a bit of a weird setup:  A small (256M) SD card
with a minimal root fs, that then bounces to a USB drive with real
spinning rust.  /etc just contains a small rc script with

echo "mounting sd0a on /mnt"
mount -o ro /dev/sd0a /mnt
echo setting sysctl
sysctl -w init.root=/mnt

I didn't want to use "root on sd0" so that I can use a generic kernel,
and theoretically the script could be made smarter to look for a
specific GUID or something.  One problem is that I can't access
/dev/ld0a once root is on /dev/sd0a - anyone has a suggestion of how
to do this better?  Even better would be if the whole thing could be
on the MSDOS partition (maybe that does work? I haven't tried...)


Joachim Thiemann :: http://jthiem.bitbucket.org ::

Home | Main Index | Thread Index | Old Index