Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: qemu for rpi emulation

On 8/13/13 10:53 AM, Sergio López wrote:
2013/8/13 matthew sporleder <msporleder%gmail.com@localhost>:
Is there a way to use qemu to emulate netbsd/rpi?
If not, what's missing?
QEMU doesn't emulate quite the same hardware that RPi bundles in its
SoC, but you can use the Integrator CP board emulation
(qemu-system-arm -M integratorcp -cpu arm1136...) and an INTEGRATOR_CP
kernel with the common evbarm userland.

The only significant drawback is that there's no SD/MMC support, so
you have to export your root filesystem via NFS from your host machine
(which is quite convenient is you're planning to do some tweaks on the



It would be helpful if you could write up (or help me, and I'll write up) the steps to get things booted using kernels from releng.netbsd.org - this way people can check whether things are broken for everyone, or just them. :)

For example, I just tried using the INTEGRATOR_CP kernel from -current (since it looks like it's not in 6.1, which makes some sense) with pkgsrc qemu:

slash:riz  ~> qemu-system-arm --version
QEMU emulator version 1.4.2, Copyright (c) 2003-2008 Fabrice Bellard
slash:riz ~> ftp http://nyftp.netbsd.org/pub/NetBSD-daily/HEAD/201308140140Z/evbarm/binary/kernel/netbsd-INTEGRATOR_CP.ub.gz Requesting http://nyftp.netbsd.org/pub/NetBSD-daily/HEAD/201308140140Z/evbarm/binary/kernel/netbsd-INTEGRATOR_CP.ub.gz 100% |***********************************| 1227 KiB 306.96 KiB/s 00:00 ETA
1256492 bytes retrieved in 00:03 (306.96 KiB/s)
slash:riz  ~> gunzip netbsd-INTEGRATOR_CP.ub.gz
slash:riz ~> qemu-system-arm -M integratorcp -cpu arm1136 -m 128m -kernel ./netbsd-INTEGRATOR_CP.ub -nographic

NetBSD/evbarm (EVBARM_BOARDTYPE) booting ...

...and it hangs there until I quit qemu. Now, I'm not exactly sure where the problem is. QEmu? The particular kernel? The way I ran it?

Any insight is helpful...


Home | Main Index | Thread Index | Old Index