Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bpf device creation as part of MAKEDEV ramdisk

On 17 August 2012 08:05, Jason Mitchell <jmitchel%bigjar.com@localhost>
> On 08/16/2012 09:32 AM, David Brownlee wrote:
>>> On 15 August 2012 11:12,  <jmitchel%bigjar.com@localhost> wrote:
>>>>> On 13 August 2012 21:11, Paul Fleischer <xpg%netbsd.org@localhost>
>>>>>> Hi,
>>>>>> I have noticed that evbarm install kernels do not have the /dev/bpf
>>>>>> devices, meaning that DHCP configuration is not possible.
>>>>>> The patch below adds bpf-devices to the ramdisk target of evbarm's
>>>>>> MAKEDEV.
>>>>>> This follows the behaviour of MAKEDEV ramdisk in other ports (cats,
>>>>>> dreamhost, evbsh3, mac68k, sandpoint, shark, and vax).
>>>>>> Ok to commit?
>>>>> Makes sense to me...
>>>> I think this is also missing from hpcarm. The last time I tried
>>>> installing
>>>> over the network I had to assign an IP address manually. I tried
>>>> searching
>>>> cvsweb.netbsd.org, but I can't find where MAKEDEV lives. I'd like to
>>>> check
>>>> this out for hpcsh as well since the installation kernels are new to
>>> It should be in etc.${port}/MAKEDEV.conf
>>> I've just taken a pass through and added bpf to all ramdisk targets
>>> (including hpcarm) in -current. If this fixes it for you then we
>>> should get it pulled up into -6 :)
>> Thanks, I'll be happy to try the install kernels out! Will,
>> http://nyftp.netbsd.org/pub/NetBSD-daily/HEAD/201208151500Z/, have the
>> changes or do I have to wait for the next build?

>I would have expected them to show up in the 20120816 or later builds...

Okay, good news and bad. The install kernel for hpcsh can successfully get
an IPv4 address via dhcpcd. However, the newer install kernels for the
JORNADA720 on hpcarm crashes. The kernel from 2012/08/13 boots, but dhcpcd
doesn't work (as expected). The kernels from 2012/08/18 & 2012/08/20 both
crash right after "WARNING: CHECK AND RESET THE DATE! with:
Fatal kernel mode data abort: 'Alignment Fault 3'
trapframe: 0xc30a9f60

Stopped in pid 1.1 (init) at     c009b268:       ldr      r1, [r1, #01x160]

The information above is the same for both install kernels. If necessary,
I can send the above info to a serial terminal so I can provide all the
detail without the effort (and errors) in re-typing.

Jason M.

Home | Main Index | Thread Index | Old Index