Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Beagleboard problems

Hi Robert,

I doubt the Beagle support is not yet available in NetBSD though some of the initial codes have been checked in long back.

When I tried with 5.0 some time back, I faced similar problem. I figured that there needed some hack in the very basic part of the temporary page table initialization (basic assembly routines). But even then, I could come only to the level where I can see console messages, permanent page table initialization, and hung after that.

Between I am not sure about the support in 5.0.1, try checking out latest CVS snapshot and see if there is any code added this time. Having JTAG connected with the Beagle will help you at least to see where it hangs.


On 08/16/2009 09:59 PM, robsch%robsch.eu@localhost wrote:

I want to install NetBSD on the beagleboard. Therefore I cross-compiled
the kernel (and the whole system) via the commands

./build.sh -u -U -m evbarm -a armeb tools
./build.sh -u -U -m evbarm -a armeb -V KERNEL_SETS=MYBEAGLE release

from the source tree in usual NetBSD-5.0.1 PC.

I copied the kernel into a FAT partition of a MMC/SD card.
Then I loaded the kernel via

fatload mmc 0 80300000 netbsd-MYBEAGLE.bin

I tried to boot the kernel via

go 80300000

No reaction. Probably crash.

Did I overlook something?

Thank you in advance.


Home | Main Index | Thread Index | Old Index