Subject: Re: cpufunc.h
To: John Fremlin <email@example.com>
From: Ben Harris <firstname.lastname@example.org>
Date: 05/28/2001 13:50:16
On 27 May 2001, John Fremlin wrote:
> Introduced are three new functions
> __SetCPSR /* Force the CPSR to a certain value */
> __set_stackptr /* set_stackptr without changing mode */
> __get_stackptr /* get_stackptr without changing mode */
> the first of which is helpful.
Why the underscores at the start? For the first, we presumably don't have
an existing SetCPSR, and for the others, wouldn't "set_current_stackptr"
be a better name (assuming that's what it does)? Is there any point in
having functions that aren't helpful?
> Would this patch be accepted?
Probably. I really need to overhaul cpufunc properly one day, but patches
to make it nicer are always helpful.
Ben Harris <email@example.com>
Portmaster, NetBSD/arm26 <URL:http://www.netbsd.org/Ports/arm26/>