Subject: Re: generic soft interrupt patch
To: Izumi Tsutsui <email@example.com>
From: Simon Burge <firstname.lastname@example.org>
Date: 04/28/2003 19:27:59
Izumi Tsutsui wrote:
> cpu_intr() in arc_trap.c should also be rewritten as noted
> in arch/arc/TODO file, but it's a future work.
> (BTW, we should rename arc_trap.c to interrupt.c like other mips ports?)
It'd be nice if we could move all softintr support to somewhere under
sys/arch/mips. Most of arc_trap.c should (with these patches) now be
the same as at least the algor, evbmips, mipsco and pmax interrupt.c
and the sbmips and sgimips softintr.c.
Simon Burge <email@example.com>
NetBSD Support and Service: http://www.wasabisystems.com/