Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD 6.1.2 install report (A1200, Bliz 1230mkIV)

I have just installed NetBSD 6.1.2 on my A1200. In doing so, I found
some problems so I'll explain how it went.

Amiga specs:
- A1200 (Commodore)
- Blizzard 1230mkIV, 68030@50, 68882@50, 64MB
- Fujitsu 120GB IDE HD (wd0)
- 3Com Gigaherz 3CXE586EC (ep0, PCMCIA... doesn't work on NetBSD yet)

First, I obtained the 6.1.2 cdimage through ctorrent (running on
AmigaOS). I don't have a cd drive on the Amiga, so I needed
diskimage.device (from Aminet) to mount it.


Reading the Amiga netbsd install guide as linked in the Amiga port
page, which I've only now realized it's outdated (by 6.1.2's)


I found I needed partitions to be in the first 4GB of the disk because
1. xstreamtodev can't write past that and 2. netbsd bootblock can't
read past that. Since I have other systems installed and I noticed a
loadbsd tool, I decided to ignore that and use loadbsd instead.

A major doubt I had while using hdtoolbox was the blocksize. Even for
foreign FSs, it must be set. And I assume it's going to affect what
the "reserved bootblocks" value actually means. So it is important. I
set it to 512 as that's the UNIX typical blocksize but I don't have
the slightest clue about how right or wrong that is regarding the
bootblocks. While I know the netbsd bootblock doesn't work, I set them
anyway, to be on the safe side.

And then, the loadbsd in the install cd didn't work. Googling around,
I found one that works:


But it doesn't support gzipped kernels. Thankfully, I had gunzip
installed on my AmigaOS. I got the install kernel to boot, and then
booted Linux to dd the miniroot into the swap partition.

With that, I was able to get to the installer.

On the installer, I had trouble with the distribution sets install
step. It asked if the partition where the files are was already
mounted, which I couldn't really answer because I had no way to go to
a shell and check at that point. So I assumed it wasn't (safer choice)
and went with a n. It didn't work, because the script assumes the
distribution sets will be found in / in the partitions it mounts.

So once I got a shell after the install script finished, I did some
mounting and repeated the process, answering y. Then I was able to
give the full path of the location of the distribution sets (phew) and
really install.

Afterwards, I booted the GENERIC kernel found in the CD. After exiting
the first shell, userspace booted, not without one surprise. mkdb
crashed and dumped a core. Clock isn't right.(Maybe fixed by the clock
driver in Current, but I don't know if it applies to A1200.)

One of the first things I figured out when first logging in is how
that GENERIC kernel is different from the /netbsd one. With the ext2
support and some help from Linux, I got that kernel into some ados
partition for loadbsd to load.

Then I did some playing around. Figured out that the PCMCIA ethernet
didn't work (as expected, because of the Amiga PCMCIA mmio space
problem). I wanted a network, so I brought SLIP up using slattach and
ser(4). At just 38400bps it is nasty, but at least I can get to the

I started X. It worked, moved mouse around for a while even... then
the served died. Apparently xterm can't get a pty. Launching just twm
with xinit works well enough.

Brought up sshd, same issue. But at the very least scp works (useful!).

Tried pkgin, but it's not installed (!). Tried to pkg_add pkgin, it didn't help.

To sum it all up, higher priority first:

Code Wishlist
- loadbsd binary shipped with the distribution should work.
- either ship a gunzip that works on AmigaOS or ship kernels, miniroot
and so on uncompressed.
- Install kernel should boot to wd0b (swap, install miniroot), not wd0a (root)
- pty's should work.
- password hash algorithm should be one that's reasonably fast for a
m68k cpu. (not 20s!)
- pkgin should be part of the sets.
- An alternative shell in a different virtual terminal should be
provided. During install too.
- xstreamtodev (poor man's AmigaOS dd) should support writing past 4GB
of a disk.
- netbsd's bootblock should work past 4GB of a disk.
- loadbsd support for loading gzipped kernels.
- ados write support.

Documentation Wishlist:
- INSTALL guide should specify what block size to set for netbsd
partitions in hdtoolbox.
- Port page should link to current distribution and not 6.0
- Port page should also link to current development version
- Port page and INSTALL guide should prominently link to boot(8),
covering loadbsd and kernel parameters.
- boot(8) should be in a text file in the distribution CD next to the
install guide.
- INSTALL guide should cover the case where loadbsd is used.
- That alt+amiga+f10 is used to invoke the system debugger should be
explained somewhere.

- What is the correct blocksize for netbsd partitions in hdtoolbox?
- Why do PTYs not work?
- How do you suggest I get pkgin installed?
- Do you want me to test anything?
- Are there known issues cross compiling Current from i386 netbsd (I
have that installed on an athlon-xp) or will I be just fine?

My current plan: Figure out how to build the Current kernel and try
doing that. Test it. Look into the nic driver to try and get the
PCMCIA nic to work on the amiga.

I attach the output of some commands for further context.

Attachment: disklabel
Description: Binary data

Attachment: dmesg
Description: Binary data

Attachment: modstat
Description: Binary data

Attachment: mount
Description: Binary data

Attachment: ps
Description: Binary data

Attachment: startx
Description: Binary data

Attachment: uname
Description: Binary data

Home | Main Index | Thread Index | Old Index