Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Possible problem with accessing DVDs larger than 4GB

Mark wrote:

>> I've been using an emulated A3000/040/SCSI CD drive config. With that,
booting NetBSD 6.0.1 and doing
>>   # dd if=/dev/cd0c of=temp.bin bs=2048
>> fails to read the last sector of the CD; e.g. if the CD has 19057
>> sectors, dd only reads 19056. (For faster testing you can add a skip=
>> argument to dd, to skip most of the disc.)
> I did some more testing. At least in WinUAE (A3000, SCSI CD drive),
> NetBSD 2.1 doesn't have that problem. It reads all 19057 sectors from
> the disc. And the same with NetBSD 1.6.2 with emulated A4000 and ATAPI
> CD drive.

Just in this minute I finished my test too. I used an A3000/060 with SCSI
CDR, running on NetBSD 6.0.

How did you determine the correct number of blocks on the CD?
I ask because NetBSD's disklabel showed me 85427 for my test CD, while
MorphOS (info blocks) displayed 85396. ;)

I tried the dd(1) command, as you wrote above, into a file, but the system
crashed (hard reboot) after a few minutes.

Then I tried it again with of=/dev/null. Now I got the expected result of
85427 blocks. No problem with 6.0 on a real A3000/060.

> So this issue could possibly be a regression in later NetBSD versions.
> Or it could be an emulation bug if earlier versions somehow accessed
> CDs differently.

I should do a test with another 6.x system to verify that.

A second test with NetBSD/macppc 5.2 and an ATAPI drive was interesting:
disklabel(8) showed 85428 - 1 block more! And dd(1) also transfered this
additional block.

So there is either a problem with the SCSI CDRom driver, or with the Amiga
port, or a general problem since NetBSD 6.

Frank Wille

Home | Main Index | Thread Index | Old Index