Subject: Re: Need help - lost access to my NetBSD partitions
To: None <>
From: Lars Hecking <>
List: port-amiga
Date: 01/31/2002 18:22:08
Ignatios Souvatzis writes:
> You're talking about the scsi configuration tool distributed with 
> Phase5's CS MkIII (and PPC) boards?


> There's a simple reason: scsiconfig _always_ disables any installed
> bootblocks[1]. After doing any change to the RDB with scsiconfig, use
> OS3.9 Hdtoolbox to set the "custom boot code" flag again, and you should
> be ok.
> (maybe even older HDTOOLBOX works to this extent, but be sure to do NO OTHER
> CHANGE to the disk with old HDTOOLBOX.)

 It certainly doesn't work with my version of HDToolBox from 3.1.

 [OT: are AmigaOS 3.5 and 3.9 ROM-based, or do they use the 3.1 kickstart

Gunther Nikl writes:
>   Well, if you really consider using HDToolBox with all its consequences
>   (loss of data), then you should try "rdbread FORCE" since it won't harm
>   then.
>   If you recreate the RDB with exactly the same partition settings then
>   you should get your partitions back. This has already worked one time

 Ok. ReadRDB tells me that the saved file is not an RDB, thus the
 recommendation to use the FORCE switch.

 It worked, but I realised that this RDB was saved before I installed
 NetBSD :-/ This is not going to happen again ...

 No big deal, I have reinstalled it, and I'm getting my config info from
 an older NetBSD install (an external disk I cannot currently use with
 the CS, so I had to plug the old G-Force back in for this).

 The geometry warnings from the NBSD kernel, however, remain

 Warning: found rdb->secpercyl(980) != rdb->nsectors(109) * rdb->nheads(9)

 and I have no idea how to fix this (if possible at all).

 Gunther and Ignatios, thanks for all your feedback!