Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ACPI S3 suspend/resume troubleshooting

On 8/26/12 2:22 PM, Grégoire Sutre wrote:
On 08/26/2012 05:45 AM, riz%NetBSD.org@localhost wrote:

Leaving out all the trouble that X is likely to bring, I'm just trying
from the text console.  When I do:

sysctl -w hw.acpi.sleep.state=3

I get messages on the console about entering S3, and flushing caches, and
the laptop appears to sleep.  (the power light blinks periodically).

However, when I try to resume (by pressing the power button), the power
light, caps lock and num lock come on, but the screen (backlight) never does.
I've tried poking various things without success.

If it's only a backlight problem, you might be able to turn
it back on with:

sysctl -w hw.acpi.acpiout1.brightness=100

I don't think it's only the backlight. The machine doesn't come back on the network, so I assume other issues are happening.

But if the laptop hangs after resume, you may want to try
different values for hw.acpi.sleep.vbios (see acpi(4)).

Yeah, I tried 0, 1 and 2.  None result in a resuming laptop. :-/


Home | Main Index | Thread Index | Old Index