Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Boot failure - port-amd64 on Intel Core i7 920 - Resolved

I'm still trying to narrow this down a bit...

It seems that if I rebuild a kernel from sources as of 2009-11-09 17:00 UTC, the system boots. Yet a kernel from sources updated to just one hour later, at 18:00 UTC, fails. The only commit during that interval was the update of sys/sys/param.h from 5.99.21 to 5.99.22 - no other source files updated!

The target system has both 5.99.21 and 5.99.22 modules in /stand/amd64/ and the same 5.99.22 modules work on all my other Intel and AMD CPUs. The modules are built from yesterday's (2009-12-17) sources.

I guess I can do a binary search to figure out when the modules broke...

Still not sure what the problem was, but a clean reinstall of both the 2009-12-17 kernel and modules works fine. So I can only assume that the original installation of the modules somehow failed silently (since I'd tried numerous kernels).

|   Paul Goyette   | PGP DSS Key fingerprint: |  E-mail addresses:      |
| Customer Service | FA29 0E3B 35AF E8AE 6651 |  paul at whooppee.com   |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at juniper.net |
| Kernel Developer |                          | pgoyette at netbsd.org  |

Home | Main Index | Thread Index | Old Index