Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Repeatable crash

This is from a 4.99.49 kernel and userland built from sources dated 2008-01-24 21:14:50 UTC

Usually, I run build.sh on the machine that actually contains the source, but this time I ran it on another host. The entire /usr/src and /usr/obj directories were NFS-mounted. The crash happens about 30 or 40 minutes after starting build.sh and it happens at different places, so I don't think it's data-specific; rather I suspect some strange race condition. The back-traces don't seem terribly usefule (maybe gdb is out-of-sync with the trap stack-frame again?).

Anyone got any hints as to what might be wrong here?

(gdb) target kvm netbsd.2.core
#0 0xffffffff802dd275 in cpu_reboot (howto=260, bootstr=<value optimized out>)
    at /usr/src/sys/arch/amd64/amd64/machdep.c:662
662                     dumpsys();
(gdb) bt
#0 0xffffffff802dd275 in cpu_reboot (howto=260, bootstr=<value optimized out>)
    at /usr/src/sys/arch/amd64/amd64/machdep.c:662
#1  0xffffffff8025f9a8 in panic (
    fmt=0xffffffff803bf2b8 <Address 0xffffffff803bf2b8 out of bounds>)
    at /usr/src/sys/kern/subr_prf.c:230
#2  0xffffffff802def84 in trap (frame=0xffff800048fa9170)
    at /usr/src/sys/arch/amd64/amd64/trap.c:264
#3  0xffffffff80100fda in calltrap ()
#4  0xffffffff8025e14b in kprintf (
fmt0=0xfc000000 <Address 0xfc000000 out of bounds>, oflags=Cannot access memory at address 0xffffffffffffff7c
    at /usr/src/sys/kern/subr_prf.c:1417
Previous frame inner to this frame (corrupt stack?)

|   Paul Goyette   | PGP DSS Key fingerprint: |  E-mail addresses:   |
| Customer Service | FA29 0E3B 35AF E8AE 6651 |  paul%whooppee.com@localhost   |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette%juniper.net@localhost |

Home | Main Index | Thread Index | Old Index