Subject: Re: libg2c has gone in NeBSD 4.99.20
To: None <>
From: Ray Phillips <>
List: port-amd64
Date: 08/21/2007 18:42:13
Thanks for replying Matthias.

>  > What's the recommended way of getting around this?
>You could try installing the "gcc3-f77" package from "pkgsrc".

Thanks a lot.  After installing that package this command worked:

./configure --with-x --with-cxxflags='-DNEED_FDSTREAM 
-DDONT_HAVE_STRSTREAM_H -DTHERMAL -ffriend-injection' 
--with-blas='-L/usr/pkg/lib -lblas -L/usr/pkg/gcc3/lib -lg2c'

and thanks Matthias.

> said:
>>  % ls -l /usr/lib/libg2c.*
>>  ls: No match.
>What happed here was that fortran support was discontinued
>when gcc4 became the official compiler. (The deeper reason
>is that gcc4's fortran support depends on libgmp and mpfr
>which are not part of NetBSD.)
>>  --with-blas='-L/usr/pkg/lib -lblas -lg2c'
>BLAS in pkgsrc is now built with help of the lang/f2c pkg.
>So it is probably sufficient to link against f2c's runtime
>library which is libF77.

Unfortunately, that didn't work.  I don't know the details of OOF's 
configure program but this command failed:

./configure --with-x --with-cxxflags='-DNEED_FDSTREAM 
-DDONT_HAVE_STRSTREAM_H -DTHERMAL -ffriend-injection' 
--with-blas='-L/usr/pkg/lib -lblas -lF77'

The last few lines of its output were:

checking for IceConnectionNumber in -lICE... yes
configure: WARNING: This is a hack to see if blas will link
checking for dgemv_ in -lm... no
configure: error: *** Supplied blas doesn't link ***

I tried reversing the order of -lF77 and -lblas in that command since 
I've read it can make a difference, but not this time.