Subject: Can't run opera on amd64
To: None <port-amd64@netbsd.org>
From: Loic Hoguin <essen@dev-extend.eu>
List: port-amd64
Date: 03/27/2007 23:23:35
   Hello,

   I'm trying to run opera on my new laptop running amd64 current.

   I compiled a kernel with COMPAT_LINUX, COMPAT_LINUX32 and EXEC_ELF32,

[root@blackrose] % sysctl -a | grep linux
emul.linux.kern.ostype = Linux
emul.linux.kern.osrelease = 2.4.18
emul.linux.kern.osversion = #0 Wed Feb 20 20:00:02 CET 2002
emul.linux32.kern.ostype = Linux
emul.linux32.kern.osrelease = 2.4.18
emul.linux32.kern.osversion = #0 Wed Feb 20 20:00:02 CET 2002

   installed the compatibility packages (well, they installed automagically)

[root@blackrose] % pkg_info | grep suse
suse_base-10.0nb3   Linux compatibility package
suse_x11-10.0nb2    Linux compatibility package for X11 binaries

   and then tried to run opera. I got the following error:

[root@blackrose] % opera
/usr/bin/opera: line 263: /usr/lib/opera/9.10-20061214.1/opera: cannot  
execute binary file
/usr/bin/opera: line 263: /usr/lib/opera/9.10-20061214.1/opera: Success

   I don't really know why it doesn't work. Does anyone have an idea?

   Thanks,

-- 
Loc Hoguin
Dev:Extend