Subject: Re: disklabel: Invalid signature in mbr record 0
To: Bernd Ernesti <>
From: Heron Gallegos <>
List: port-amd64
Date: 12/18/2006 13:44:41
On Mon, 18 Dec 2006, Bernd Ernesti wrote:
> You missed the fdisk part.
> disklabel needs a MBR on that disk.
> Make sure that you reserve some space at the begining of the disk
> (63 sectors) when you create the mbr label for NetBSD (type 169).
> You could get into trouble if you do not reserve this space, like
> windows overwritting these sectors.

Thanks, Bernd.

I ran "fdisk -u sd1" using the default (suggested) values. Now
the output of "fdisk sd0" and "fdisk sd1" shows both disks are
exactly the same values. Thanks again, Bernd.

At this point, (my curiosity and previous to disklabel), I ran the
commands "disklabel sd0" and "disklabel sd1" to see how is my
second disk now and how it should be. I found some interesting
differences: (sd0 was fdisked and disklabeled by sysinst and sd1
by me)

disk    sd0     sd1
type:   unknown SCSI
disk:   mydisk  mydisk
label: <empty>  fictitious
rpm:    3600    10025

My fdisk detects correct values for type and rpm in sd1.
This last comment was just for curiosity.


Heron Gallegos
Saltillo Coahuila Mexico