Subject: Re: ACPI interrupt routing, take 2
To: Frank van der Linden <>
From: Jonathan A. Kollasch <>
List: port-amd64
Date: 04/03/2006 15:37:22
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Thu, Mar 23, 2006 at 12:44:48AM +0100, Frank van der Linden wrote:
> I've updated my changes for ACPI interrupt routing, and put new kernels
> in
> Changes are:
> 	* Fixes from Masanori Kanaoka for legacy IRQ use and cardbus.
> 	  (should fix legacy IRQ problems that a few people saw).
> 	* Get the ioapic register settings right for ioapic routes
> 	  using a PCI link device (should fix problem reported
> 	  by Matt Thomas).
> 	* More debug output if you patch the kernel to have mp_verbose =3D 2
> 	  (e.g:
> 		gdb --write netbsd.acpi
> 		set mp_verbose=3D2
> 		quit
> 	  )
> 	* Stepping through the MPACPI configuration, requiring user a
> 	  console keypress, if mpacpi_step =3D 1.
> Many thanks for the testers who helped so far,
> - Frank

Ok, something odd happened, for reasons beyond my control
my system now has 4GiB in it (w/o hole remapping (as I
want to use X), so 3.5GiB).  The netbsd.acpimp kernel
worked when I had 2GiB in the box.  Now, however, the
thing reboots during the dmesg.  The last thing I see
is mpbios something.  I don't have a null modem around
here unfortunately.

(A few other things in the bios may have changed too, so
this might not be the fault of this amount of memory.)

On the plus side, last week's test worked perfectly.
I intended to test this on a few i386 boxes too.

Great work.  I hope to see this committed as soon as
it's ready.

	Jonathan Kollasch

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.4.2 (NetBSD)