Subject: Re: sun fire V40Z running NetBSD
To: Brett Lymn <>
From: matthew sporleder <>
List: port-amd64
Date: 10/27/2005 10:56:35
'top' has never shown real memory statistics for me on NetBSD.
At one point, I looked into switching it to use sysctl
hw.physmem/usermem, but got kind of lost in the code.  (I'm not much
of a c guy)

It's good to hear that it worked, though.

On 10/27/05, Brett Lymn <> wrote:
> Folks,
> Last week I was at the AUUG 2005 conference where they had a Sun Fire V40=
> which was part of the display that Sun put on for the conference.  On
> the last day we were allowed to install other operating systems onto
> the beast - the OpenBSD guys put theirs on (it worked FWIW), and I
> then installed NetBSD onto the machine, cross built a MP on my laptop
> and booted to that.  With the short testing I did NetBSD performed
> flawlessly on the machine.
> The machine specs were quad dual core opterons (8 cpus in other
> words), 16Gb of RAM, two U320 SCSI hard drives.
> About the only problem I noticed was that top was not entirely happy
> with displaying the memory size correctly - the amount of free memory
> reported by top was off by a long way (an order of magnitude or so).
> I think the problem is confined to top because vmstat seemed to report
> the correct numbers...