Subject: ``K8, issue #93''.
To: None <>
From: Richard Rauch <>
List: port-amd64
Date: 04/29/2004 07:22:58
I'm presently running my AMD64 box in a 3-way boot.  Partition
#1 has NetBSD, but some of the stability issues (plus an itch
to see DRI running; (^&) pushed me to look at other systems.

I tried FreeBSD, but it was a bit rough.  SuSE GNU/LINUX also had
problems when I last tried it.  However, a recent Mandrake GNU/LINUX
is running---and, I think, is running more stably than NetBSD.

The reason for my posting here is that the GNU/LINUX kernel comes up
with a report about a ``K8'' issue (typed by hand):

****** Your BIOS seems to not contain a fix for K8 errata #93
****** Working around it, but it may cause SEGVs or burn power.
****** Please consider a BIOS update.
****** Disabling USB legacy in the BIOS may also help.

...and I thought that it might help in isolating the problems
in NetBSD if I forwarded this information.

I have the latest BIOS already, as far as I know.

I could not find "legacy" options for USB, but perhaps that's
just a synonym for something else?  I could disable USB 1.1
when booting Mandrake...but for NetBSD, I think that I need
USB 1.1.

I also tried disabling all of the hardware that NetBSD does
not support at this time:

 * The RealTek 8169 NIC.
 * The USB 2.0 (leaving USB 1.1).
 * SATA and RAID.
 * 1394/Firewire.
 * A few others that I cannot remember offhand.

Since disabling the 8169, USB 2.0, and Firewire, I have not
pushed the LINUX boot very hard, but NetBSD still crashes with
UVM faults.  (E.g., "make clean" at the top level in /usr/pkgsrc,
and NFS mount, just crashed NetBSD a few minutes ago.  NetBSD
synced the disks, but got held up by an NFS error ("server not
responding" was printed after the green kernel messages; no
"Press any key to reboot" message appeared; printable keys printed
on the console; nothing else seemed to do much).

[Oh, another incidental factoid: In the recent past, I was able
to improve system stability, e.g., to compile X or clean all of
/usr/pkgsrc, by using ^Z periodically.  I thought that the
CPU might be overheating, but BIOS says it stas at 40 degrees C.
I installed some more system fans, and that seems not to have made
any difference.  I have not tried that recently, but assume that
it's still true.  The fact that GNU/LINUX *seems* much more
stable under load makes me skeptical.  Also, it was once upon
a time quite stable under load with NetBSD.)

Is it worth trying to disable USB 1.1?  My mouse is a USB mouse,
and I'd like to hook up some other USB devices, but if someone
thinks that USB 1.1 is a likely source of my problems, I can
give that a try.

My NetBSD instability issues seem to have spiked up after leaving
the machine running for an undetermined time in i386 mode (running
an i386 version of LINUX; it crashed overnight).  But also around
that time, I upgraded BIOS from something like ``F4'' to ``F11'',
and also not long before that I put in a post-2.0 NetBSD/amd64

Reverting to older installations is a bit painful because some
of my older -current boot CDs only have the GENERIC kernel.
(My system is *very* unhappy if I do not disable IOAPIC.)

Around December/January, I had some very stable NetBSD/amd64
installs on this box, once I had removed IOAPIC.  (Enabling
IOAPIC is not a good idea unless the problems with using it
on this nForce3 chipset have been resolved.  With IOAPIC
turned on, as described elsewhere, some hardware simply never
works, and other hardware will work for a while and then at
random times will stop working until a reboot.)

Anyway, just some random bits of info.  Maybe it will help
someone get a better handle on the instability that some
of us are seeing.

  "I probably don't know what I'm talking about."