Subject: Re: Windows stuck
To: None <>
From: Richard Rauch <>
List: port-amd64
Date: 03/28/2004 03:55:37
This is a known problem.  I believe that others have confirmed it on the
Alpha, so it's not just us.

It appears to be the X server losing the button-up mouse event.  The window
manager is fine.  (There's a PR open on this; I forget the number but I
filed one in around November.)  Some more information, mostly in the PR:

 * If you drag the mouse quickly while releasing, this causes the up event
   to be lost.
 * It does not appear to be in the kernel that this is happening.  (A patch was
   sent to me by a kernel developer whose name eludes me at the moment.  The
   patch counted button up and button down events, then reported if it ever
   fell out of the 0-or-1 range.  It never reported problems.)
 * If you click the mouse button again, and don't move it while you release,
   the X server will get the button-up event.
 * If you dump the /dev/wsmouse data, it appears to be working correctly.
 * I know that this applies to USB; I think it applies to PS/2 mice, too.

Something that may be related that I do not think I have commented on before:

When I hit the CapsLock key (yes, I do sometimes use it) in X, the whole
X server freezes up for about 1 second.  (I have not tried any experiments
to see if it seizes up remote logins.)

If I use CapsLock on a text console, it does not have this problem.

NumLock has the same effect.  ScrollLock does nothing at all.  (It
doesn't even change the LED to indicate ScrollLock.)  (I haven't tried either
of these on a text console...)

XFree86 definitely has some input handling issues.  (^&

  "I probably don't know what I'm talking about."