Subject: Re: Failure to install on AMD64
To: Richard Rauch <>
From: John Goerzen <>
List: port-amd64
Date: 02/25/2004 08:14:22
On Tue, Feb 24, 2004 at 06:55:41PM -0600, Richard Rauch wrote:
> On Tue, Feb 24, 2004 at 08:20:38AM -0600, John Goerzen wrote:
> > I'll certainly do that, but my initial problem is a little different.
> > It's not even getting far enough to load *any* kernel.  It seems as if
> > something is screwy with my bootblocks.

Or perhaps GRUB.  While I've always been able to chainload to NetBSD
from GRUB on i386 machines, on this one, once I installed bootselect, it
worked right off.  I don't know if this is because of amd64 differences
or because of differences in hard disk size (160GB here; I've never
booted off anything larger than 80GB with NetBSD before).

However, I have run into two strange I/O errors: 1) a "soft error"
("lost interrupt") every so often on my IDE device (though it never
seems to actually cause a problem other than a 60-second delay), and 2)
my network card goes down after a few minutes of use.

I pulled an old crappy -- but supported -- PCI realtek from another
machine and slapped it in this box.  Worked for awhile, then got a bunch
of watchdog errors about rtk0 on the console.  (The on-board nvidia
device is not supported in NetBSD)

I am hoping at this point that I have the APIC problem you described.
However, with an unreliable network connection and hard disk, combined
with the fact that I've never built any part of the NetBSD base system
before, I'm not really sure that I'll be able to build a new kernel :-)

> Okay, I misunderstood.  I assumed that the kernel was loading but dying
> early.  (I was assuming that some critical device was failing causing
> the boot to fail before you got anywhere.)
> If you know that it is not even reading in the kernel file, then
> nevermind me.  (^&

Well your advice turned out to be relevant a little later on anyway :-)

-- John