Subject: RE: nVidia motherboards?
To: 'Frank van der Linden' <>
From: NameAdmin <>
List: port-amd64
Date: 10/18/2003 13:49:33
For what it is worth:
I have had no problems with an ASUS SK8N with the nForce 3 chipset. I have
been successful booting with both IDE and using an Adaptec 2110 u160
controller.  I have not had success using the onboard sata raid controller,
though I doubt that is a surprise!


-----Original Message-----
From: [] On
Behalf Of Richard Rauch
Sent: Saturday, October 18, 2003 1:42 PM
To: Frank van der Linden
Subject: Re: nVidia motherboards?

Well, I used the old video card.  Perhaps I didn't have the CD-ROM cables
seated properly, but I couldn't get the video signal to go away and
stay away.  (But then again, that doesn't mean a whole lot based on
the lack-of-pattern that I did see.)

I tried three ways of booting:

 * Old 1.6 i386 install on the hard drive.

 * Quite recent i386 -current.

 * The 20031005 snapshop of AMD64.

They all gave varying and strange results.  Since I was on a local console,
I had to manually transcribe the errors.  Here are some of them:

AMD64 image:

* ...
  total memory 512 MB
  avail memory 468 MB
  using 6144 buffers containing 26292 KB
  fatal page fault in supervisor mode
  trap type 6 code 2 rip ffffffff80243ad0 cs 8 rflags 10213 cr2
  cpl e rsp ffffffff808d1e80
  The operating system has halted.
  Please press any key to reboot.

* WARNING: invalid time in clock chip.
  root file system ffs
  warning: no /dev/console
  init: creating mfs /dev
  uvm_fault(0xffffffff80889460,0xffff80012353a000,0,2) -> e
  fatal page fault in supervisor mode
  trace type 6 code 2 rsp f..ff80243ad0 cs 8 rflags 10203 cr
  cpl 0 rsp ffff800023464b50

1.6 HD:

* WARNING: invalid time in clock chip
  root filesystem type: ffs
  Fri. Nov 29 04:19:41 GMT 2002
  swaptctl adding /dev/wd0b as swap device at priority 0
  starting fs checks
  kernel: page fault trap, code = 0
  stopped at       rnd_add_uint32+0x13e: addb  %al, 0(%eax)

-current CD

* Crashed to "db>" prompt (some of the other crashes did, too; others
  would lock tight, or leave me at a "press any key to reboot").
  In this case, it happened *during* an attempted install, while
  unpacking sets.

  uvm_fault (0xe31c1480,0,0,2) -> 0xe
  kernel: page fault trap, code = 0
  stopped in pid 1842.1 (gzip) at 0xc0ee5673: addb %al, 0(%eax,%eax,1)

I've also noticed that (when the AMD64 .iso boots and lets me get to
installing) it objects about "disk full" when attemping to MAKEDEV
in /dev.  And, too, it sometimes cannot find my hard disk (attempting
to install objects that it cannot find a disk to install to).

The system is supposed to do a memory test after a cold start (it is *very*
quick, but I assume that everything passes).  It runs okay in BIOS.  Even
here, it can run for a while (going as far as a newfs of a disk and
to unpack data.)

I *have* tried reseating the memory; the system still acts odd.

In all of theses cases, the OS was being loaded over the IDE interface,
though.  Maybe that's a bit flakey somehow and is corrupting some of the
data that it reads?

One of the oddities of the BIOS is that it has swapped labels and
help/description info for some of the IDE options and for the built-in
LAN.  The option reads "<LAN interface>" and the description is
about disabling/enabling the IDE RAID.  Conversely, the option
names the "RAID", while the description talks about the LAN.

  "I probably don't know what I'm talking about."