Port-alpha archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Xorg, XFree on netbsd/alpha

Am 20.09.2011 21:33, schrieb Manuel Bouyer:
> On Tue, Sep 20, 2011 at 09:52:11AM +0200, Robert Dörfler wrote:
>> Hi,
>> i just installed NetBSD5.1 on my AlphaPC 164LX some days ago.When i was
>> starting X i realized that its not the usual xorg/xfree86.Its
>> XdecNetBSD. I'm just wondering why its included on the
>> iso-distribution.
>> Isnt there an usual xorg/xfree86 package around for alpha?
> By default the alpha port still uses the old XFree86 tree, but you
> should be able to rebuild from source with X11FLAVOUR=Xorg
> (I did use it when I still had a working alpha XP1000)

Its been some while. If i try to build Xorg it stops compiling at
"/usr/pkgsrc/sysutils/libpciaccess" with:

ERROR: This package is only available for these platforms: FreeBSD-*-i386 NetBSD-*-i386 OpenBSD-*-i386 FreeBSD-*-x86_64 NetBSD-*-x86_64 OpenBSD-*-x86_64 DragonFly-*-i386 DragonFly-*-x86_64 Linux-*-* SunOS-*-* NetBSD-*-sparc64.
ERROR: This package has set PKG_FAIL_REASON:
ERROR: libpciaccess-0.11.0nb1 is not available for NetBSD-5.1_STABLE-alpha
*** Error code 1

So, i tried to add NetBSD-*-alpha as platform in the Makefile and
libpciaccess will build with a few warnings knowing that this will
surely will crash later. So, i tried to build modular-xorg-server
which will end here:

alpha_video.c:44:21: error: xf86Axp.h: No such file or directory
alpha_video.c:59: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'bsdGetAXP' libtool: compile: cc -DHAVE_CONFIG_H -I. -I../../../../include -I../../../../hw/xfree86 -I../../../../hw/xfree86/include -I../../../../hw/xfree86/common -I../../../../hw/xfree86/os-support -I../../../../hw/xfree86/os-support/bus -I../../../../os -I/usr/obj/pkg/x11/modular-xorg-server/work.lobos/.buildlink/include -I/usr/obj/pkg/x11/modular-xorg-server/work.lobos/.buildlink/include/freetype2 -DUSESTDRES -DHAVE_XORG_CONFIG_H -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_REENTRANT -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/usr/obj/pkg/x11/modular-xorg-server/work.lobos/.buildlink/include/pixman-1 -I../../../../Xext -I../../../../composite -I../../../../damageext -I../../../../xfixes -I../../../../Xi -I../../../../mi -I../../../../miext/shadow -I../../../../miext/damage -I../../../../render -I../../../../randr -I../../../../fb -O2 -pipe -mieee -MT bsd_axp.lo -MD -MP -MF .deps/bsd_axp.Tpo -c bsd_axp.c -fPIC -DPIC -o .libs/bsd_axp.o

After fixing that, i got:

misym.c:127: warning: 'miPointerAbsoluteCursor' is deprecated (declared at ../../../mi/mipointer.h:126)xf86sym.c:702: error: 'outw' undeclared here (not in a function)
xf86sym.c:703: error: 'outb' undeclared here (not in a function)
xf86sym.c:704: error: 'outl' undeclared here (not in a function)
xf86sym.c:705: error: 'inb' undeclared here (not in a function)
xf86sym.c:706: error: 'inw' undeclared here (not in a function)
xf86sym.c:707: error: 'inl' undeclared here (not in a function)

misym.c:128: warning: 'miPointerCurrentScreen' is deprecated (declared at ../../../mi/mipointer.h:131)gmake[4]: *** [xf86sym.o] Error 1

misym.c:130: warning: 'miPointerWarpCursor' is deprecated (declared at ../../../mi/mipointer.h:111)
gmake[4]: *** Waiting for unfinished jobs....
mv -f .deps/misym.Tpo .deps/misym.Po
mv -f .deps/loadmod.Tpo .deps/loadmod.Po
gmake[4]: Leaving directory `/usr/obj/pkg/x11/modular-xorg-server/work.lobos/xorg-server-1.6.5/hw/xfree86/loader'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/obj/pkg/x11/modular-xorg-server/work.lobos/xorg-server-1.6.5/hw/xfree86'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/obj/pkg/x11/modular-xorg-server/work.lobos/xorg-server-1.6.5/hw/xfree86'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/obj/pkg/x11/modular-xorg-server/work.lobos/xorg-server-1.6.5/hw'
gmake: *** [all-recursive] Error 1
*** Error code 2

make: stopped in /usr/pkgsrc/x11/modular-xorg-server
*** Error code 1

make: stopped in /usr/pkgsrc/x11/modular-xorg-server

Home | Main Index | Thread Index | Old Index