Port-alpha archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: writing cdhdtape to CD

Have you tried to mount the first slice in the image? Something like
 mount /dev/vnd0a /mnt

You should be able to check what slices are in the image with disklabel too.


                  | ~ ~ |
                 ^( @ @ )^

Anders Hogrelius
Tessingatan 12
SE72216 Vasteras

Phone: +46 70 677-0210
Skype-In No: +1 714 408-7868

On Thu, 28 May 2009, Ray Phillips wrote:


I can't check the CD at the moment, but the cdhdtape file should be a good place to start...

I think the cdhdtape image file I have is OK, based on the facts that it's the same size as this one:


(there's not an md5 value for it on ftp.netbsd.org that I can check against) and I can dd it to a hard disk and boot the PWS from that disk successfully.

I've totally failed to mount cdhdtape though. I guess I'm doing something wrong:

# uname -mrs
NetBSD 5.0 i386
# ls -li
total 3714
4659209 -rw-------  1 ray  wheel     1984 Apr 26 16:54 README.files
4659210 -rw-------  1 ray  wheel  3776512 Apr 26 16:54 cdhdtape
# md5 cdhdtape
MD5 (cdhdtape) = 2165582d6591ca74a9a483c3522e52a8
# vnconfig -l
vnd0: not in use
vnd1: not in use
vnd2: not in use
vnd3: not in use
# vnconfig -v -c vnd0 cdhdtape
/dev/rvnd0d: 3776512 bytes on cdhdtape
# vnconfig -l
vnd0: / (/dev/wd0a) inode 4659210
vnd1: not in use
vnd2: not in use
vnd3: not in use
# mount /dev/vnd0d /mnt
mount_ffs: /dev/vnd0d on /mnt: incorrect super block
# mount_ufs /dev/vnd0d /mnt
mount_ufs: /dev/vnd0d on /mnt: incorrect super block
# mount_ffs /dev/vnd0d /mnt
mount_ffs: /dev/vnd0d on /mnt: incorrect super block

I tried mounting NetBSD-5.0/i386's boot-big.fs file using this approach too as a test, but kept getting this 'incorrect super block' error. I'll be happy if you can point out my mistake.


Home | Main Index | Thread Index | Old Index