Subject: corrupted disklabel and bootstrap failure
To: None <>
From: None <>
List: port-alpha
Date: 04/06/2005 08:40:45
I installed NetBSD 2.0 from CD to a 600mhz 164LX Alpha. During installation
when it goes through the "I found only one disk therefore I assume you want
to install netbsd to it..." part, there is message displayed to the screen
that says:

sd0: Netbsd disk label corrupted

At this point I can hit enter to continue and go through a normal NetBSD
installation. However after the installation I reboot the system and back
at the SRM prompt I attempt to boot from the disk:

>>>boot dka0
(boot dka0. -flags AL)
block 0 of dka0. is not a valid boot block
bootstrap failure

This is happening to two seperate hard drives, one of which previously had
NetBSD 2.0 for Alpha installed to it (on the same system about 2 months
ago), and the other hard drive was brand new out of the box with no
filesystem on it (the brand new drive the first time I attempted
installation did not complain about a corrupt disklabel, simply a missing
disklabel - but after NetBSD was installed to it, then I started getting
the disklabel corrupted messages on subsequent installation attempts)

I have performed a dd on one of the drives to see if wiping it would help
but that did not seem to make a difference when I performed an
installation. I got the same result during the NetBSD install as well as
when the drive was attempted to boot from in SRM.

I did find this NetBSD mailing list post from a while back but I am not
sure these symptoms are caused by the same problem, especially because it
previously had netbsd working on it and also the problem posted was from
2-3 years ago:

I have not tried installing NetBSD to an IDE drive using the onboard IDE
controller yet, but amazingly I am having some difficulty tracking down a
spare IDE drive to attempt with. Most likely I will be able to later this
week but I'm not sure this is purely a SCSI related issue.

My SRM version is 5.8-1
SCSI card is a 53c895 or possibly 53c896
Hard drives are both Seagate SCSI drives

Any ideas on what may be causing this, or anything else I could try?