Subject: Alpha xsrc build issues
To: None <>
From: Michael Kukat <>
List: port-alpha
Date: 10/17/2004 21:15:10

after fiddling around for several days with pkgsrc/x11/XFree86-server, and
finally got some kind of useable package from this, i saw, buildlinking and
stuff seems not yet really complete for pkgsrc XFree. So i built xsrc (from
current CVS), which works fine (seems to at least... we know the trouble on
MIATAs), and installes the driver modules as shared objects. But if i do a make
snapshot release, the packing list for xserver4.tgz wants to use XdecNetBSD
(which is what i wanted to get rid of btw :), but not the "full-featured"
XFree86 server with all those driver modules for those cheap cards for having
24bit graphics. XdecNetBSD wasn't even build. Is this problem known? Is a fix
for the packing list current in progress? What's different in the precompiled
OS installation packages? They also seemed to be XFree86 4.4.0.

Just curious, and if there is help needed, maybe i fix up the packing list to
get a useable distribution for the Alphas. But this would not make sense if
there is a defniitive idea behind the things i have seen.

If it's of interest, it's 2.0RC4 what i have running as OS under this, and for
now it runs very stable. Added some i386 config file stuff to alpha to get ehci
and wscons complete. I can confirm ehci also working fine on alpha (some cheap
NEC-based 5port USB2.0 PCI card).


--    Home Powered by: (Net|Open|Free)BSD IRIX NonStop-UX
Solaris AIX HP-UX Tru64 MUNIX Ultrix VMS SINIX Dolphin_Unix OpenStep MacOS A/UX