Subject: Re: no luck with X on 164SX board
To: Joachim Kuebart <>
From: David Hopper <>
List: port-alpha
Date: 04/05/2004 09:45:00
I have no experience with the 164xx models, but the SX has the same=20
21174 core chip as the LX (albeit a different PCI --> ISA bridge, which=20=

shouldn't matter).  I do know that X on alpha is very sensitive to=20
different video card types, and may not work even between board revs. =20=

For example, I could get most 8 meg MGA-2164W cards to work, but others=20=

simply would not (the cards were fine).  Some cards like the Voodoo 3=20
would give me an SRM console, but X would fail on them (this apparently=20=

works now, but I have not tested mine).

It's all still quite trial-and-error, although the new in-tree 4.4 is a=20=

great improvement.  Your best bet would be to borrow a purported=20
'working' card and give it a shot, or find a computer outlet that has a=20=

liberal return policy.

Mel, can you add to this list?

I know that most Matrox Millennium II MGA-2164W cards work, Radeon 7000=20=

(PWS 600au), NVidia GeForce 440MX, and this particular Diamond S3=20
ViRGE-DX (Alphastation 255).


On Apr 5, 2004, at 6:54 AM, Joachim Kuebart wrote:

> Hi,
> so many alpha-users on this list seem to be running X, but so far I am=20=

> out
> of luck. I'm running -current as of April 2, and I tried both Mel's=20
> 4.4.0
> as well as in-tree X sources. My hardware is a 21164PC-2 CPU in a =
> board (instead of the 164LX board that most people are using). I don't
> possess any of the successfully tested graphics boards, but I tried=20
> cards
> for the s3, ati and tdfx drivers, all with the same effect:
> 	root@jaja:joki# xinit
> 	XFree86 Version 4.4.0
> 	Release Date: 29 February 2004
> 	X Protocol Version 11, Revision 0, Release 6.6
> 	Build Operating System: NetBSD/alpha 2.0B [ELF] The NetBSD=20
> Foundation, Inc.
> 	Current Operating System: NetBSD jaja 2.0B NetBSD 2.0B=20
> (ALPHA-$Revision: 1.191 a
> 	Build Date: 05 April 2004
> 	Changelog Date: 29 February 2004
> 		Before reporting problems, check http://www.XFree86.Org/
> 		to make sure that you have the latest version.
> 	Markers: (--) probed, (**) from config file, (=3D=3D) default =
> 		(++) from command line, (!!) notice, (II) informational,
> 		(WW) warning, (EE) error, (NI) not implemented, (??) =
> 	(=3D=3D) Log file: "/var/log/XFree86.0.log", Time: Mon Apr  5 =
> 2004
> 	(=3D=3D) Using config file: "/etc/X11/XF86Config"
> 	unexpected machine check:
> 	    mces    =3D 0x1
> 	    vector  =3D 0x660
> 	    param   =3D 0xfffffc0000006068
> 	    pc      =3D 0x1202a829c
> 	    ra      =3D 0x1202889b0
> 	    code    =3D 0x211
> 	    curlwp =3D 0xfffffc0000e29860
> 		pid =3D 459.1, comm =3D XFree86
> I'm using the WSDISPLAY_COMPAT_* options and INSECURE in the kernel=20
> config,
> but no XSERVER as it is supposed to have no effect. I tried several
> different configurations of the XF86Config file (including none at=20
> all),
> removing and uncommenting modules and using ShadowFB and NoAccel=20
> options,
> but it doesn't change anything. Does anyone have any ideas what is =
> likely my problem? Should I just go and buy one of the recommended=20
> G400 or
> Radeon cards?
> Any help is appreciated,
> cu Jo
> --=20
> La perfection est atteinte non quand il ne reste rien =E0 ajouter, =
> quand
> il ne reste rien =E0 enlever.  (Antoine de Saint-Exup=E9ry)