Subject: Re: httpd blocked in sokva
To: Paul Mather <>
From: Herb Peyerl <>
List: port-alpha
Date: 04/02/2004 08:49:15
On 2-Apr-04, at 8:21 AM, Paul Mather wrote:

> I did a little searching and it appears others have had this problem.
> Someone reported that building a kernel with the SOSEND_NO_LOAN option
> enabled (to disable zero-copy sockets on the send side) appeared to
> solve the problem they had.  I'll try that, although it may be hard to
> tell if this does solve the problem, as it is likely quite hard to
> reproduce it in my case.
> Has anyone else noticed this having happened on their system?  With
> release engineering about to begin for NetBSD 2.0, it would be sad to
> have that ship with a bug like this.
I was one of the ones reporting this issue on i386.  I run a couple of 
fairly busy webservers and they were both encountering this every 1-2 
days.  Recompiling with SOSEND_NO_LOAN solved the problem and it's not 
happening anymore.  However, I think a fix for this was checked in to 
-current sometime after 1.6ZF.  So you shouldn't be seeing it after 
that, in theory.