Subject: Re: Spam that makes SpamAssassin crash Perl
To: Anders Hogrelius <>
From: Paul Mather <>
List: port-alpha
Date: 11/29/2003 10:53:11
On Sat, Nov 29, 2003 at 12:17:55PM +0100, Anders Hogrelius wrote:

=> Well, I tried compiling perl 5.8.2, and it seems this must be caused by
=> something within the system. I'm running NetBSD 1.5.2, and even with the
=> latest version of perl, I still get:
=> ahs@hogrelius:~> perl -e 'print exp(0 - 736.285624221884), "\n";'
=> 0
=> Perhaps one should look for the cause within the compiler or the math
=> library? I compiled perl using gcc 2.95.3.

There have historically been problems with IEEE arithmetic on
NetBSD/alpha.  I know I ran into them back in 1999 trying to get R to
install from pkgsrc.  (See, e.g., and the
thread at

I believe Ross Harvey fixed this, though I don't remember exactly
when.  Also, I've always run -CURRENT on my alpha, so I don't know
when these types of fixes make it into which particular official

I do have a vague recollection (that may be entirely wrong:) that
"-mieee" appeared as default option on alpha builds after the fix went
in, so if you are seeing "-mieee" when, say, building packages, then
your version of NetBSD probably includes the fixed IEEE handling.




"Without music to decorate it, time is just a bunch of boring production
 deadlines or dates by which bills must be paid."
        --- Frank Vincent Zappa