Subject: Re: Spam that makes SpamAssassin crash Perl
To: Simon Burge <>
From: Rhialto <>
List: port-alpha
Date: 11/28/2003 02:29:15
On Fri 28 Nov 2003 at 12:21:51 +1100, Simon Burge wrote:
> FWIW, I have an slightly older version of perl (perl-5.6.0nb3), compiled
> with gcc 2.95.3 in late 2000, and I see the same problem:
> Compiling the current pkgsrc perl with gcc 2.95.3 on a 1.6V box using
> NetBSD sources from late June does work though:
> 	alpha 3> perl -e 'print exp(0 - 708), "\n";'
> 	3.30755300363841e-308

but -708 was working for me too - maybe this was a paste error?

> > Next question: how to fix that?
> What vintage is your Alpha's userland?

It is still 1.6, I have been planning to upgrade to 1.6.1 but haven't
got around to it yet.

> I can't see anything between perl-5.6.1nb7 and perl-5.6.1nb9 that
> looks like it obviously would change anything.  A first step would
> be to upgrade your perl package and try again...

I'll set the build process in motion right away.

> Simon.
___ Olaf 'Rhialto' Seibert
\X/ rhialto/at/        -- Cetero censeo "authored" delendum esse.