Subject: Re: AlphaServer 2000 4/200 support?
To: None <>
From: Jochen Kunz <>
List: port-alpha
Date: 07/15/2003 00:13:55
On 2003.07.14 21:35 Wilko Bulte wrote:

> According to the PDFs I just studied the CPUs modules are the same.
> AS2000 can house 2, AS2100 can house 4 of them.
> I guess memory is the same too.
Perfect. The man I got the AS2000 from has the cards from a AS2100. The
PSU from the AS2100 let the magic blue smoke out. As the machines had to
go out of the house he took out the cards and trashed the rest.=20

Can I access these PDFs somewhere?=20

> > I still need help to get this beast out of my car and into my flat.
> > [...] the AS2000 is to much steel.=20
> Heh ;) Too much steel, this is True DEC Iron(TM)=20
Yes. This is the way real machines have to be build.=20
(Why do I think of a VAX 6000 while typing this? ;-) )

Meanwhile I found a friend that helped me to bring the beast into my
flat. I had to solve some funky errors with the old ethernet card. (Lots
of PCI bus errors only because I switched from 10Base5 to 10Base2!? I
replaced it with a newer 100BaseT card but SRM doesn't get packets out
of it.) I instaled a DEFPA and tried to boot, see below:
P00>>>sh conf
                        Digital Equipment Corporation
                           AlphaServer 2000 4/200

SRM Console V5.3-2              VMS PALcode V5.56-7, OSF PALcode

Component       Status          Module ID

 Slot   Option                  Hose 0, Bus 0, PCI
   1    NCR 53C810              pka0.            SCSI Bus ID 7
                                dka600.          RRD43
   2    Intel 82375                                     Bridge to Bus 1,
   6    DEC PCI FDDI            fwa0.          =20
   8    DECchip 21140-AA        ewa0.          =20

 Slot   Option                  Hose 0, Bus 1, EISA
   2    Compaq Qvision                             =20
P00>>>sh dev
dka600.             DKA600                        RRD43  1084
dva0.0.0.1000.0            DVA0                      RX26/RX23
ewa0.               EWA0              00-C0-95-FA-64-F2
fwa0.               FWA0              00-A0-24-61-DC-8E
pka0.               PKA0                  SCSI Bus ID 7
P00>>>boot -prot bootp fwa0
(boot fwa0.

Trying BOOTP boot.

Broadcasting BOOTP Request...
Received BOOTP Packet File Name is: netbsd
local inet address:
remote inet address:
TFTP Read File Name: netbsd
netmask =3D
Server is on same subnet as client.
bootstrap code read in
base =3D 200000, image_start =3D 0, image_bytes =3D 7149c4
initializing HWRPB at 2000
initializing page table at 27ff0000
initializing machine state
setting affinity to the primary CPU
jumping to bootstrap code

halted CPU 0

halt code =3D 2
kernel stack not valid halt
PC =3D 0              =20

The kernel I tried to boot is:
$ uname -a
NetBSD ickis 1.6R NetBSD 1.6R (GENERIC) #0: Fri May 16 01:56:42 CEST
2003  toor@Zimbo:/usr/src/src-current/objdir-alpha/sys/arch/alpha/compile=

Sugestions for further hacking affords welcome.=20