Subject: panic in -CURRENT
To: None <>
From: Paul Mather <>
List: port-alpha
Date: 06/30/2003 14:54:33
Is there a big set of updates ploughing through -CURRENT right now?  I
ask because I've not been able to complete a run the last
couple of times I've tried.  To top things off, the latest kernel I
managed to build suffered a panic due to a memory management fault
trap. :-(

About a week ago I tried to rebuild my userland after building a new
kernel, but the userland failed, complaining about a lack of
an "opt_multiprocessor.h" file.  Last night, I re-rsync'ed my sources
and set off another tools and kernel build.  When I came back this
morning, it, too, had failed, complaining about an incorrect number of
arguments in a function (sorry, I forget which).  So, I rsync'ed again
and set it off building.

The kernel built from this morning's sources compiled cleanly.
However, when I rebooted with it, my system soon suffered a panic.
This happened about the time FVWM was loading the XPM background
bitmap in my X session during startup.  From a serial console, I
captured the following output:

CPU 0: fatal kernel trap:
CPU 0    trap entry = 0x2 (memory management fault)
CPU 0    a0         = 0x24
CPU 0    a1         = 0x1
CPU 0    a2         = 0x0
CPU 0    pc         = 0xfffffc00004641d8
CPU 0    ra         = 0xfffffc00004640f8
CPU 0    pv         = 0xfffffc00004640e0
CPU 0    curlwp    = 0x0
panic: trap
syncing disks... 6 6 5 4 3 2 1 1 done
dumping to dev 8,9 offset 811
dump 256 255 254 253 252 251 250 [[etc.]] 5 4 3 2 1 succeeded

This is on NetBSD 1.6U (HAWKWIND) #0: Mon Jun 30 09:23:31 EDT 2003,
running on DEC 3000/300 hardware.

I've reverted back to my old kernel for now (also a 1.6U-CURRENT
kernel, but built June 25th), which is stable.

The reason why I'm keen to re-build my userland is because after
moving to 1.6T or thereabouts, emacs stopped working (it dumps core
during startup).  There is a fix in the ports Makefile for this, but I
suspect my binutils is out of sync with that the Makefile presumes it
should be from my kernel version number.  I figured upgrading kernel
and userland so both were in sync completely might solve that problem,
allowing me to re-build emacs and have it working again.  But it seems
I may have hit a bad time to try and successfully run :-)




"Without music to decorate it, time is just a bunch of boring production
 deadlines or dates by which bills must be paid."
        --- Frank Vincent Zappa