Subject: > 1 GB RAM problems on PWS
To: None <>
From: Ray Phillips <>
List: port-alpha
Date: 05/27/2003 17:54:29
Dear port-alpha:

I thought the problem(s) created by having more than 1 GB RAM in a 
PWS had been fixed, but some seem to be lingering on, at least in 

I've had 1 GB in my PWS 500 for four or five weeks now and have 
exercised it a fair bit by doing numerous builds from cvs sources, 
all without any apparent problems (after giving up on my ISP1020 
anyway).  However, when I increased the RAM to 1152 MB error messages 
from the SCSI controller began appearing on the console, sometimes 
stopping the machine from responding and requiring a power cycle. 
When I removed the extra 128 MB the error vanished.

This happened with both a Symbios SCSI controller:

siop0 at pci1 dev 8 function 0: Symbios Logic 53c875 (ultra-wide scsi)
siop0: using on-board RAM
siop0: interrupting at dec 550 irq 12
scsibus0 at siop0: 16 targets, 8 luns per target

Some of the errors were:

May 23 20:33:51 siop0: unable to load cmd DMA map: 22pws500 /netbsd: 
sd0(siop0:0:0:0): adapter resource shortage
ccd0: error 16 on component 1

and with a QLogic ISP1040B (don't ask me why it probes as a 1020):

isp0 at pci1 dev 10 function 0: QLogic 1020 Ultra Wide SCSI HBA
isp0: interrupting at dec 550 irq 20
scsibus0 at isp0: 16 targets, 8 luns per target

Some of the errors were:

sd0(isp0:0:0:0): generic HBA error
May 25 19:29:48 pws500 /netbsd: isp0: unable to load dma (22)
May 25 19:29:48 pws500 /netbsd: sd0(isp0:0:0:0): generic HBA error

Should I file a PR about this?