Subject: Re: XFree86 on PWS machines - update
To: mel kravitz <>
From: Reinoud Zandijk <>
List: port-alpha
Date: 11/28/2002 01:10:14
Hiya Mel,

On Wed, Nov 27, 2002 at 01:29:41PM -0500, mel kravitz wrote:
> Saw your 11/7 post to the list... a little late. If i may ask what
> patches do you have installed to xsrc/......./os-support/bsd/bsd_axp.c
> /bsd/bsd_video.c and xsrc/..../programs/Xserver/Makefile.
> any other patches applied? In 4.0.2 PLT errors were controlled with
> /Xserver/Makefile change @line ~218 change to:
> EXTRA_LOAD_FLAGS = -W1, -Bstatic

That does the trick yeah ... thanks a lot.

> in addition 'glint' driver needs Option "ShadowFB" in XF86Config file.

did that too in the device part .. is that ok?

> with these present XFree86-4.0.2 runs with :
> mga driver...Matrox bds to G200.
> glint driver....Elsa, 3-Dlabs(410T) and Diamond Fire1000 -permedia2 chip
> bds.
> i have tested it with the above vga bds and it is very stable.

SNIF ... well i am glad it worked for you!! mine just needed another 
powercycle *sigh*. It seems like X or something else is probing the PCI bus 
wrong or so like the last time. Its screen got black and the only thing 
working was numlock and capslock... all other stuff was DEAD. Not pingable 
etc... even the reset button was dead.

I compiled the Xserver alone (XFree4) from scratch with no patches other 
than the ones you gave me. The rest of the X system i had allready build 
from xsrc/xfree myself before.

My kernel config is still the same : i.e. with the following patches :

> cvs diff -u GENERIC
RCS file: /cvsroot/syssrc/sys/arch/alpha/conf/GENERIC,v
retrieving revision 1.219
diff -u -r1.219 GENERIC
--- GENERIC     2002/11/05 08:31:43     1.219
+++ GENERIC     2002/11/27 23:55:26
@@ -129,7 +129,7 @@
 options        LKM
 # Disable kernel security.
-#options       INSECURE
+options        INSECURE
 # Misc. options
 options        EISAVERBOSE             # recognize "unknown" EISA devices
@@ -283,7 +283,7 @@
 siop*  at      pci? dev ? function ?           # Symbios 53c8xx SCSI
 mlx*   at      pci? dev ? function ?           # Mylex DAC960 / DEC SWXCR (untested)
 ne*    at      pci? dev ? function ?           # NE2000-compatible Ethernet
-ohci*  at      pci? dev ? function ?           # USB Open Host Controller
+#ohci* at      pci? dev ? function ?           # USB Open Host Controller
 pceb*  at      pci? dev ? function ?           # Intel PCI-EISA Bridges
 pciide*        at      pci? dev ? function ?           # PCI IDE controllers
 pcscp* at      pci? dev ? function ?           # AMD Am53c974 PCscsi-PCI
@@ -456,7 +456,7 @@
 # USB bus support
 usb*   at uhci?
-usb*   at ohci?
+#usb*  at ohci?
 # USB Hubs
 uhub*  at usb?

My machine Hates usb so i uncommented the ohci and the usb; it otherwise 
gives scheduling overruns with no devices connected (AHUM). I know its a 
busspace_barrier thingy but where and what..... It gives problems with the 
IDE discs.

> I recently built video programs from pkgsrc..'mplayer' and 'ogle'
> which show the limitations of 'no accel' server. Both run however.
> I just got a 600a, converted it to scsi and running current, a screen
> shot is at 
> Look forwarded to hearing from you.

Hmm... could it be that its interrupt related? i.e. the USB getting 
polled/detected by the PCI code and issueing a kind of interrupt that gets 
served by the wrong driver or whatever?? something messing up completely?

It strikes me that the IDE disc lights are allways on when it crashes... 
hopefully we can crack this problem.... Could you send me your XFree86 
binary to test? might be working due to a patch in your tree.. and if 
possible could you also send me your kernel?