Subject: Netscape panics 1.6I kernel
To: None <>
From: Paul Mather <>
List: port-alpha
Date: 10/12/2002 16:40:13
I just built a new kernel as a precursor to building a new userland
only to discover that netscape will now panic the machine. :-\

This is on a NetBSD/alpha 1.6I-CURRENT system:

NetBSD hawkwind 1.6I NetBSD 1.6I (HAWKWIND) #1: Sat Oct 12 15:48:11
EDT 2002     root@hawkwind:/usr/src/sys/arch/alpha/compile/HAWKWIND

Netscape worked okay under the previous 1.6H kernel on my DEC
3000/300.  Here is the panic message:

panic: kernel diagnostic assertion "cmd->ev_vp->v_flag & VTEXT" failed: file "/sys/arch/alpha/compile/HAWKWIND/../../../../kern/exec_subr.c", line 142
Stopped in pid 258 (sh) at      cpu_Debugger+0x4:       ret     zero,(ra)
db> trace
cpu_Debugger() at cpu_Debugger+0x4
panic() at panic+0x168
__assert() at __assert+0x34
vmcmd_map_pagedvn() at vmcmd_map_pagedvn+0x50
sys_execve() at sys_execve+0x57c
syscall_plain() at syscall_plain+0x154
XentSys() at XentSys+0x58
--- syscall (59) ---
--- user mode ---

Netscape is the only thing so far that has triggered this panic.  Does
this mean the OSF compatibility is temporarily broken?

Here is the output of "file" on my Netscape binary:

/usr/local/netscape/netscape: COFF format alpha executable paged dynamically linked stripped - version 3.11-10

(I just tried to run ldd on the binary, but it paniced the machine in
exactly the same way! :-\)

Do you think this problem will clear up when I finish building a new




"Without music to decorate it, time is just a bunch of boring production
 deadlines or dates by which bills must be paid."
        --- Frank Vincent Zappa