Subject: Re: Blank Screen
To: None <>
From: Ray Phillips <>
List: port-alpha
Date: 06/24/2002 17:46:46
Mel's patched XFree86 4.0.2 code 
( worked on my PWS 500 which 
is running NetBSD/alpha 1.5.2 and has a VGA card.  Well, I'm new to X 
so all I've done is run startx and xinit, but that's a lot further 
than I'd advanced previously.

I've tried three cards: Matrox Millennium G200 (with the mga driver), 
PowerStorm 4D10T and ELSA Gloria Synergy (both with the glint driver).

I should check the set of instructions appended to this message to 
make sure it contains no errors, but IIRC those were the steps I 


Remove or rename  /usr/X11R6 and /etc/X11  if they exist.

# cd /tmp
# ftp
# ls -l
total 108208
-rw-r-----  1 ray  wheel  110731943 Jun  6 15:27 xsrc.tar.gz
# md5 *z
MD5 (xsrc.tar.gz) = 5668a4a63d1db0c0c81fd1fe618833d0
# cd /usr
# pax -zrpe -f /tmp/xsrc.tar.gz
# cd xsrc/xfree/xc
# make clean
# make includes
# make
# make install

This will create /usr/X11R6 and /etc/X11.  /usr/include/vm/vm.h is 
required for make to work; it's in NetBSD 1.5.2 but is apparently 
missing in versions later than 1.5V.

Make a copy of the GENERIC kernel configuration file, and modify the copy thus:

1) uncomment the second of these two lines:

# Disable kernel security.
#options         INSECURE

2) add this line:

pseudo-device    wsmux 2

then build a new kernel from the new configuration file.

In /etc/rc.conf change NO to YES in this line:

wscons=NO               wscons_flags=""         # setup wscons from wscons.conf

In /etc/ttys replace the lines:

ttyE0 "/usr/libexec/getty std.9600"   vt100 off secure
ttyE1 "/usr/libexec/getty std.9600"   vt100 off secure

with these:

ttyE0 "/usr/libexec/getty std.9600"   vt100 on secure
ttyE1 "/usr/libexec/getty std.9600"   vt100 on secure
ttyE2 "/usr/libexec/getty std.9600"   vt100 on secure
ttyE3 "/usr/libexec/getty std.9600"   vt100 on secure

Create /etc/X11/XF86Config using xf86config or manually.  If using 
xf86config, change wsmouse to wsmouse0 in InputDevice section:

     Option "Protocol"    "wsmouse"
     Option "Device"      "/dev/wsmouse0"

To stop the console presenting just a black screen after exiting X, 
in /etc/X11/XF86Config change the

Option "AutoRepeat"

setting to

Option "AutoRepeat" "500 5"

When using the glint driver this line must be in the video card's 
Device section or the server will crash:

Options "ShadowFB"

Because of the new kernel configuration for the console you will not 
be able to login to the boot screen.  Instead type ctrl-alt-F2 to 
bring up a login prompt on one of the alternate consoles and use it.

If the installation was successful,

# X -scanpci

will return the PCI device locations, and xinit and startx will start 
an X session.