Subject: Re: Stubborn DEC 3000/600 install
To: None <>
From: Matt <>
List: port-alpha
Date: 05/13/2002 10:41:08
On Mon, May 13, 2002 at 01:58:58AM -0400, Roland Dowdeswell wrote:
> On 1020981902 seconds since the Beginning of the UNIX epoch
> Matt wrote:
> >22:27:33.099777 arp reply is-at 0:10:4b:93:b:40
> >22:27:33.101408 > [no cksum] 26 tftp-#0 [t
> >os 0x1]  (ttl 30, id 2447, len 54, bad cksum e414!)
> >
> > I can see that an attempt is at least made from the Alpha. I've
> >tested a TFTP get from another box on the same wire and that works okay.
> Hmm, looks like the alpha might be sending a malformed TFTP request?
> I'm not sure about this one as I've never run into it, but it
> appears that the diskless machine is the last one to communicate
> and sends a packet with a bad checksum.  Perhaps the server drops
> it and the communication ends there?  I've not owned a TC-based
> alpha, so I can't really comment on the likely firmware problems
> that you may run into on this one.

I've managed to sort the problem, eventually! :-)

The current SRM firmware version was 3.2, and after google'ing for a
fair bit, I found a post that stated 3.2 wouldn't netboot, a symptom
being the Alpha arp'ing for, which my tcpdump session shows.

Unfortunately, I couldn't get the 7.0 firmware update to start over MOP
either, so after a rather helpful pointer from a private reply, I
managed to get access to the original DU4 install, (I got the box
"ex Uni", so I had no login details, and zero DU experience), and used
another google posting to master the update on to a tape instead of
a floppy. However, the first drive I used was a QIC 250MB drive, and
for some strange reason, this won't work under DU4, I just got I/O
errors whenever I tried to access the drive. Next drive was a DAT and
this worked without problem.

Rebooted and the update utility booted okay, and so I've upped the
firmware to 7.0 now.

The Alpha now netboots using BOOTP/TFTP, the NetBSD install fires off
without a hitch, and to rub salt in, the original firmware update also
works over MOP :-).

I don't know if somewhere in the above there is a useful FAQ for the
future... I feel I've learned something anyway...