Subject: X and mouse: return
To: None <>
From: Michael G. Schabert <>
List: port-alpha
Date: 12/31/2001 20:40:33
Hi guys,

AlphaStation 200 4/166, running the binary snapshot that was posted a 
week or so ago.

Running make USETOOLS=never depend, and make USETOOLS=no, I was able 
to successfully compile a custom kernel. I started out with an ALPHA 
cconfig file, commented out all non-avanti CPUs, all 
non-PCI/ISA/PCMCIA stuff, no USB, etc. I changed
pms*   at      pckbc?
wsmouse*        at      pms?


pmsi*   at      pckbc?
wsmouse*        at      pmsi?

The kernel built fine, & I installed it & rebooted. The dmesg had
pmsi0 at pckbc0 (aux slot)
wsmouse0 at pmsi0 (mux ignored)

so it lookled successful. I logged in, typed "startx" & watched as 2 
xterms, xclock, xosview and tvtwm all sprung to life :-). I typed 
something into one xtterm, highlighted it with mouse button 1. I then 
moused over to the other xterm window & hit the scroll wheel, and the 
text popped into view! Woohoo. Next, I typed "emacs /build-12-30" to 
see if the scroll wheel does anything (build-12-30 is the "script" 
output from my attempt to I saw emacs pop onscreen, & 
waited a bit until the text of the build came up. I scrolled the 
mouse wheel & nothing happened :-(. OK, I thought, so the rest worked 
no problem. So I tried to mouse up to exit emacs....but I couldn't 
find my pointer! I tried ctrl-c...nothing. OK, I went to my Mac, 
started up BetterTelnet, & logged in so that I could kill emacs. 
Hmmmm, no emacs. Even better, no xterm, xosview, or xclock, or 
Xalphanetbsd. Harumph. "startx" again. I go over to the alpha's kbrd, 
& hit "x-return" a few times, & see the login at console come up. 
startx again, see the usual complement come up, & move the mouse 
again. This time, I find that I already have nothing, but am back 
into console, without seeing the window (but with retrying, I can 
logout blindly and it will come back into view). I had tried checking 
my home directory for .core files, but none were created.

So I typed "script /xservertxt", followed by "startx". Here's the 
output (^M's deleted):

alpha# startx

xrdb: colon missing on line 1, ignoring line

Fatal server error:
alphaMouseEnqueueEvent: unrecognized id

xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
X connection to :0.0 broken (explicit kill or server shutdown).
xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
X connection to :0.0 broken (explicit kill or server shutdown).
xinit:  connection to X server lost.

7.102u 0.982s 1:23.56 9.6%      0+0k 0+37io 0pf+0w

Any ideas?

Bikers don't *DO* taglines.