Subject: Re: Miata 500a and NetBSD
To: Jason Kaufman <>
From: Reinoud Zandijk <>
List: port-alpha
Date: 12/17/2001 02:55:35
Hiya Jason,

On Wed, Dec 12, 2001 at 10:21:07AM -0500, Jason Kaufman wrote:
> I purchased a 500a in August and have been trying to get NetBSD on it
> ever since.

Just bought myself one too and its running NetBSD fine now for some time; I 
first tried to boot it from the CD drive but unlucky me it didn't work for 
my CDROM drive apeared to be broken ... just a waranty thing but still ... 

Then i tried to boot it from floppy and install stuff from the network but 
that didn't work either for the default NetBSD driver for the build in card 
was at that time not that stable/usable.... it has been improved and it 
said to be running fine now; I cheated and used a cheap PCI ethernet card 
(RealTec) and that works great :)

> The first issue with the 500a is getting a SCSI controller that is SRM-
> compatible.  Mine shipped with an incompatible Adaptec-2940UW.  After
> about a month of searching I came across a Qlogic ISP 1020 card that
> I thought would work great.  But during the package installation process,
> the NetBSD installer caused a machine check.

Now this is _very_ weird... the Miata or DEC Personal Workstation 500au has
an *onboard* SCSI controller.... what else do you think the harddisc is on
:) not IDE for sure !! ;-) So you allready have one ... access it as dkc0 
or so. Use `show device' to see what devices are there.

> > There are any problems using IDE disks ? (My miata has a 1 scsi and 1 IDE
> > disk)

The big IDE discs appeared to have problems but that proved to be just a
faulted harddisc ... it broke not soon after. The new 40Gb Seagate EIDE 
disc works fine and AFAIK the SRM can even boot from it !

> As you probably already know, the Miata won't boot from an IDE hard disk.
> I've never tried accessing a spare IDE drive under Linux.

is it ? hmm... 

> The only additional hardware I have in the 500a is an extra 256MB of RAM from
> Crucial, and the ISP 1020.  The SCSI drive is the original 4.3GB (Seagate,
> I think).  My SRM version is 7.x.  I have been assured by others that 
> my SCSI configuration is correct, so what gives?

Oh.... extra 256Mb RAM ... hmm... need to buy some for more yes...