Subject: PMAZ and PMAD on a DEC3000/300
To: None <>
From: Michael Olbricht <>
List: port-alpha
Date: 04/19/2001 00:11:18

I am new to the NetBSD port for Alpha (have used pmax before).

I have installed NetBSD/Alpha-1.5-Release on a DEC3000/300,
and it works very well, even under heavy I/O with four disks
and le0 at the same time.

But the PMAZ-A board present at TC0 can't be used:
the kernel skips it with
"asc (53c94 SCSI) at tc0 slot 0 offset 0x0 not configured".
I have used the release kernel as well as self-compiled kernels
from GENERIC and TCWSCONS - all with the same result.

What do I have to change to enable that card, if it works at all?


As seen in the dmesg output below, le1 (a PMAD in TC1) fails 
due to a known problem ("Reg did not settle") WRT
/usr/src/sys/dev/dec/if_le_dec.c .
A ">>>t tc1 init" in advance did not help, BTW.


Yes, I know there are better boards than the PMAZ, but
I haven't got one of those - yet. 
I had bought both cards for my DECstations, but since lists them as
supported, I tried to use them in DEC3000s.
However, the install notes list PMAD as untested (should be:
currently not supported?), and none of PMAZ, PMAZB and PMAZC. 

Getting a statement about what option boards actually work
would be helpful for buying some more. ;-)
Maybe reports from users (like this) can give some feedback
for an overview of working combinations.

Bye and thanks in advance

Complete dmesg output:

[ preserving 445000 bytes of netbsd ELF symbol table ]
consinit: using prom console
Copyright (c) 1996, 1997, 1998, 1999, 2000
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 1.5 (GENERIC) #10: Wed Nov 22 03:00:56 PST 2000
DEC 3000 - M300, 150MHz
8192 byte page size, 1 processor.
total memory = 32768 KB
(2048 KB reserved for PROM, 30720 KB used by NetBSD)
avail memory = 22040 KB
using 204 buffers containing 1632 KB of memory
mainbus0 (root)
cpu0 at mainbus0: ID 0 (primary), 21064-1 (pass 3)
tcasic0 at mainbus0
tc0 at tcasic0: 12.5 MHz clock
sfb (Smart Frame Buffer) at tc0 slot 6 offset 0x2000000 not configured
ioasic0 at tc0 slot 5 offset 0x0: slow mode
le0 at ioasic0 offset 0xc0000: address 08:00:2b:3c:29:83
le0: 32 receive buffers, 8 transmit buffers
scc0 at ioasic0 offset 0x100000: console
scc1 at ioasic0 offset 0x180000
mcclock0 at ioasic0 offset 0x200000: mc146818 or compatible
AMD79c30 at ioasic0 offset 0x240000 not configured
tcds0 at tc0 slot 4 offset 0x0: TurboChannel Dual SCSI (baseboard)
tcds0: fast mode set for chip 0
asc0 at tcds0 chip 0: NCR53C94, 25MHz, SCSI ID 7
scsibus0 at asc0: 8 targets, 8 luns per target
le1 at tc0 slot 1 offset 0x0le: Reg did not settle (to x0): x181
: address 08:00:2b:23:64:37
le1: 32 receive buffers, 8 transmit buffers
asc (53c94 SCSI) at tc0 slot 0 offset 0x0 not configured
scsibus0: waiting 2 seconds for devices to settle...
probe(asc0:2:0): max sync rate 5.00MB/s
sd0 at scsibus0 target 2 lun 0: <DEC, RZ28     (C) DEC, 435E> SCSI2
0/direct fixed
sd0: 2007 MB, 3045 cyl, 16 head, 84 sec, 512 bytes/sect x 4110480
probe(asc0:3:0): max sync rate 5.00MB/s
sd1 at scsibus0 target 3 lun 0: <DEC, RZ26     (C) DEC, 392A> SCSI2
0/direct fixed
sd1: 1001 MB, 2570 cyl, 14 head, 57 sec, 512 bytes/sect x 2050860
root on sd0a dumps on sd0b
root file system type: ffs
Michael Olbricht
machinarum occultarum domi alienae custos et pontifex