Subject: Re: PWS 433a Ethernet problem?
To: None <,>
From: Ross Harvey <>
List: port-alpha
Date: 04/14/2001 00:02:20
> From: Wes Kurdziolek <>
> There are some strange problems w/ tulip NICs and some hubs and/or
> switches. I've noticed it on a PWS 500au -- when I connect it to the
> network at work, it connects to a Cisco switch, but at home, I have an
> off-brand switch. At work, it works great, but at home, I have the same
> problems you're describing. Also, it doesn't seem to matter which
> operating system I'm running, although I've only tried Linux, NetBSD, and
> FreeBSD. Maybe it's not a NetBSD-only problem?

For many tulip-series interfaces, FreeBSD and NetBSD use the same driver,
written by a NetBSD developer, so the same behavior would actually be
expected. What's Linux? (:-)


> On Fri, 13 Apr 2001, Tom Haapanen wrote:
> > About a month ago I emailed about a problem installing NetBSD onto a PWS
> > 433a from floppy and/or CD.  Couldn't resolve those, despite help from
> > several people.  and then spent most of the next month out of the office.
> > ::: 21142 :::
> > I have a feeling I am missing something very obvious here, but I fear I'll
> > soon go bald if I keep pulling my hair out at this rate.

I think that's a 21143, actually.

I don't think it's something obvious. Just last week I failed _myself_ (for
the first time ever #$&@*#@!) to get NetBSD installed. It was on a PWS 433au,
and I just couldn't get de0 to work; my theory was that it was probably OK
at 100mb, but I needed it to work at 10. I tried all the usual incantations.
I think it's our driver, because the netboot worked fine right up until
the kernel tried to mount the root FS.

I'm fairly certain we worked in the past at 10mb on that box.