Subject: Re: need INSECURE kernel for the XFree86 Xserver to work.
To: Andrew Brown <>
From: Jason R Thorpe <>
List: port-alpha
Date: 01/15/2001 13:54:43
On Mon, Jan 15, 2001 at 03:40:23PM -0500, Andrew Brown wrote:

 > so the aperture driver hasn't been ported, or won't?

The Aperture driver is irrelevant here... it doens't have any idea
about the way inb/outb is emulation on the alpha (which INSECURE is
also needed for).

Face it -- XF86 is insecure software, and people should be aware of it.
And it will continue to be insecure until they fix their broken bus
access model (they had a glorious opportunity when they re-architected
for XF86 4, but of course they didn't take advantage of it, even though
several people prodded them to do so).

        -- Jason R. Thorpe <>