Subject: pc146 running ~current, sh not "happy"
To: None <>
From: Andrew Brown <>
List: port-alpha
Date: 12/13/2000 23:26:46
my alpha's up now (thanks to all who gave helpful suggestions and
hints) and is happily running current code ( of right before
the ubc integration).  one thing remains.

i recently noticed that my sh isn't very well behaved.  i accidentally
type 'set -o emacs' twice (typed it once, and then hit up/return by
accident), only to have my single user shell quit on me.  i logged in
again and did it again.  and again.

after sh does this

   Abort trap (core dumped)

gdb tells me this about the core dump.

   GNU gdb 4.17
   Core was generated by `sh'.
   Program terminated with signal 6, Abort trap.

   warning: Hit heuristic-fence-post without finding

   warning: enclosing function for address 0x12007b51c
   This warning occurs if you are debugging a function without any symbols
   (for example, in a stripped executable).  In that case, you may wish to
   increase the size of the search with the `set heuristic-fence-post' command.

   Otherwise, you told GDB there was a function where there isn't one, or
   (more likely) you have encountered a bug in GDB.
   #0  0x12007b51c in ?? ()

which is not very helpful.  typing in bt at this point does this

   pid 1048 (gdb): unaligned access: va=0x12022123b pc=0x120015cb4 ra=0x120015cc0 op=ldq
   gdb in free(): warning: modified (chunk-) pointer.
   Segmentation fault (core dumped)

and that's that.

i tried rebuilding libl, libedit, libtermcap, libc, and sh, but it
still does the same thing.  i haven't yet tried rebuilding gdb, but
that doesn't seem like it will fix the problem.

is anyone else seeing anything like this?

|-----< "CODE WARRIOR" >-----|             * "ah!  i see you have the internet (Andrew Brown)                that goes *ping*!"       * "information is power -- share the wealth."