Subject: Re: sshd keygen...
To: None <>
From: Peter Seebach <>
List: port-alpha
Date: 12/07/2000 00:51:07
In message <>, Andrew Gillham write
>Hmm, I saw something kind of like this when I hadn't rebuilt the libcrypto
>library.  Basically the DSA keygen during boot would just sit there for ages
>on my Multia.  I always pressed ctrl-c, so I don't know if it would have
>finished.  After rebuilding libcrypto it was pretty fast.  It takes about 9
>seconds for the RSA key, and 127 seconds for the DSA key. (I just rebooted
>and tested it)

Hmm.  Mine still seems hosed, even with libcrypto rebuilt.  Well, just in
case I'll rebuild everything in sight.

>I think it gave me some warning though, perhaps about how xyz encryption
>wasn't built into libcrypto.  Anyway, if it is still running, I can't see
>how it is working correctly. (seeing how my multia is a 166Mhz pooch)

Yeah, it certainly ought to be faster than this.  I suppose if all else fails
I can do the debugger thing.  *sigh*.

Ah-hah!  ssh-keygen is static, not dynamic, and I hadn't actually linked it
with the newly built libcrypto.  Hmm.  Still no luck.  *sigh*.  Or at least,
it's well past 9 seconds of CPU time on a 500Mhz 21164.

I'm going to let it try to generate a DSA key and see how long *that* takes.
This is the first time I've tried to do this with the stuff in
/usr/src/usr.bin/ssh, so I could be doing something wrong; I'm just doing
'sh rc.d/sshd start'.  Nope!  More than two minutes, so, again, something