Subject: Re: Problems with Promise IDE controllers on NetBSD/alpha
To: Joel Votaw <>
From: Luke Mewburn <>
List: port-alpha
Date: 10/11/2000 18:13:07
Joel Votaw writes:
> I have NetBSD running on an AlphaPC 164, and am trying to add a Promise
> IDE controller (I have both an Ultra/33 and Ultra/66 controller) to it.
> Obviously, I have to use a -release or -current kernel to do this.  I have
> tried 1.4.3_ALPHA, NetBSD-release and 1.5_ALPHA2, with both cards, with
> INSTALL and GENERIC and custom kernels, from boot floppies and
> instkernels, and all give the same kind of error.
> For example, under 1.4.3_ALPHA, from an instkernel:
> Can anyone see what I am doing wrong?  Or where to start debugging it?  
> How could I tell if this were a hardware problem?  (I think the Promise
> cards are okay, but with all of this hardware reconfiguration I may have
> flexed the motherboard or something.)  Is there an alternative to these
> Promise POS cards?

I plugged a Promise UltraATA/100 card into my PC164 which has an NCR
53c810 SCSI controller & serial console (and has worked flawlessly for
more than 12 months), and 1.5_ALPHA2 panics with:

	pciide0 at pci0 dev 6 function 0: Promise Ultra100/ATA Bus Master IDE
	Accelerator (rev. 0x02)
	pciide0: bus-master DMA support present
	pciide0: primary channel configured to native-PCI mode
	pciide0: using eb164 irq 0 for native-PCI interrupt

	unexpected machine check:

	    mces    = 0x1
	    vector  = 0x660
	    param   = 0xfffffc0000006060
	    pc      = 0xfffffc00004c79f8
	    ra      = 0xfffffc000031dd64
	    curproc = 0xfffffc0000564830
		pid = 0, comm = swapper

	panic: machine check
	Stopped in swapper at   cpu_Debugger+0x4:       ret     zero,(ra)

So, you're not the only one.

And to think I was going to make the Alpha into my server, because my
x86 box has started going flaky ...