Subject: Problems with Promise IDE controllers on NetBSD/alpha
To: None <>
From: Joel Votaw <>
List: port-alpha
Date: 10/10/2000 22:01:51
I have NetBSD running on an AlphaPC 164, and am trying to add a Promise
IDE controller (I have both an Ultra/33 and Ultra/66 controller) to it.
Obviously, I have to use a -release or -current kernel to do this.  I have
tried 1.4.3_ALPHA, NetBSD-release and 1.5_ALPHA2, with both cards, with
INSTALL and GENERIC and custom kernels, from boot floppies and
instkernels, and all give the same kind of error.

For example, under 1.4.3_ALPHA, from an instkernel:

/netbsd: pciide0 at pci0 dev 6 function 0: Promise Ultra33/ATA Bus Master
IDE Accelerator (rev. 0x01)
/netbsd: pciide0: bus-master DMA support present
/netbsd: pciide0: primary channel configured to native-PCI mode
/netbsd: pciide0: using eb164 irq 0 for native-PCI interrupt
/netbsd: unexpected machine check:
/netbsd:     mces    = 0x1
/netbsd:     vector  = 0x660
/netbsd:     param   = 0xfffffc0000006060
/netbsd:     pc      = 0xfffffc0000589e64
/netbsd:     ra      = 0xfffffc000034ab64
/netbsd:     curproc = 0xfffffc00006bc6a0
/netbsd:         pid = 0, comm =
/netbsd: panic: machine check
/netbsd: halted.
/netbsd: [ preserving 356920 bytes of netbsd ELF symbol table ]

Booting from the 1.5_ALPHA2 boot floppies, it says that it died in

I tried hitting 't' in the debugger (on a 1.5_ALPHA2 kernel) to get a
trace but got no output (it just returned to the prompt immediately).

I have tried moving the card to another slot (tried all four PCI slots)
and that hasn't helped.  I have tried booting with a minimal set of
devices (this IDE card, the Elsa GLoria video card, and no drives on the
onboard IDE); again, no luck.

I have tried changing the IRQ of one of the COM ports in the kernel config
file (it was also trying to use IRQ 3, and I suspected PCI bus-mastering
devices and ISA devices would not cope well with that); also no luck.

I'm reasonably new to the NetBSD kernel and have read in archives of this
list that other people have gotten this working.  I've tried all of the
debugging tricks I can think of and am out of ideas.

FWIW, this is a standard AlphaPC 164 board, 500MHz 21164, 128MB of RAM
across four SIMM slots, a version of SRM that is about 9 months old, a
motherboard battery that is about 9 months old, and it's been running
NetBSD 1.4.2 with four hard drives (on the onboard controllers) like a
champ for several months.

Can anyone see what I am doing wrong?  Or where to start debugging it?  
How could I tell if this were a hardware problem?  (I think the Promise
cards are okay, but with all of this hardware reconfiguration I may have
flexed the motherboard or something.)  Is there an alternative to these
Promise POS cards?

Thanks in advance for any advice,