Subject: pkg: php-gd-3.0.16
To: None <,,>
From: Mocha <>
List: port-alpha
Date: 05/10/2000 03:20:57
this is not an alpha related Q. but it's the only list i'm on. so maybe one 
of you have seen this error too. i was trying to build the 
pkg  php-gd-3.0.16. got this error:

alpha500# make
===> Validating dependencies for php-gd-3.0.16
===> gd-1.8.1 uses X11, but /usr/X11R6 not found
*** Error code 1

i thought it was kind of ridiculous to require a full install of x11 src 
just to compile gd. so i dug a little deeper. gd  pkg depends on xpm 
package, cause it needs the xpm.h file. xpm pkg will not build. seems quite 
old and not maintained. but anyone know why it's looking for /usr/X11R6?

here is the out put from make in xpm:
alpha500# pwd
alpha500# make
===> xpm-3.4k uses X11, but /usr/X11R6 not found

gd pkgsrc's Makefile have this line:

CPPFLAGS+=      -I${X11BASE}/include -I${X11BASE}/include/X11   # xpm.h

shouldn't it be looking for the xpm.h where ever the xpm pkg installed it? 
not everyone installs X11.