Subject: Re: Problems with tosha on alpha
To: None <>
From: Curt Sampson <>
List: port-alpha
Date: 01/24/2000 03:12:28
On Mon, 24 Jan 2000, Curt Sampson wrote:

> When I run tosha on my fairly current alpha with a SCSI CD-ROM and
> an Adaptec 2940, it reads the table of contents just fine, but when
> I start reading a track, it panics the system....

As a follow-up, it works fine with both drives on an NCR 53c812 controller:

    ahc0 at pci0 dev 5 function 0
    ahc0: interrupting at eb164 irq 2
    ahc0: Reading SEEPROM...done.
    ahc0: aic7880 Wide Channel, SCSI Id=7, 16 SCBs
    ahc0: Resetting Channel A
    ahc0: Downloading Sequencer Program...Done
    scsibus0 at ahc0 channel 0: 16 targets, 8 luns per target
    ncr0 at pci0 dev 7 function 0: ncr 53c810a fast10 scsi
    ncr0: interrupting at eb164 irq 1
    ncr0: minsync=25, maxsync=206, maxoffs=8, 16 dwords burst, normal dma fifo
    ncr0: single-ended, open drain IRQ driver
    ncr0: restart (scsi reset).
    scsibus1 at ncr0: 8 targets, 8 luns per target
    scsibus1: waiting 2 seconds for devices to settle...
    cd0 at scsibus1 targ 0 lun 0: <, CD-R/RW RW7040S, 1.10> SCSI2 5/cdrom removable
    cd1 at scsibus1 targ 6 lun 0: <PIONEER, CD-ROM DR-124X, 1.01> SCSI2 5/cdrom removable

Also, the problem where a

    dd if=/dev/rcd0a of=image.iso bs=2048

used never to complete (on ahc0) has meliorated itself somewhat,
but I still get about 140 MB of data when I run the above command
on a disk that, when mounted, has less than 70 MB of data on it.
(Could this be just some weirdness in how this particular CD was

Curt Sampson  <>   917 532 4208   De gustibus, aut bene aut nihil.
The most widely ported operating system in the world: